vim初期インストール時の対応

概要

新規でvimをインストールする際に出たエラーに関する対応のメモ。

エラー

vimpythonが追加されない

sudo apt-get install python-dev
  • 原因2
    • pythonのconfigフォルダを指定してあげる必要がある
# 今回実行したコマンドは下記
./configure --with-features=huge --enable-multibyte --enable-pythoninterp --enable-gpm --enable-cscope --enable-fontset --with-python-config-dir=/usr/lib/python2.7/config-x86_64-linux-gnu
  • メモ
    • 追加されているかどうかは、「vim --version」で確認できる

起動時にエラーが発生

  • 概要
  • エラー内容
    • 以下の様なメッセージが大量に出る
E10: \ の後は / か ? か & でなければなりません
  • 原因
    • vi互換を切る必要があるらしい
" (1) .vimrcに、以下の記述を入れる
set nocompatible
" (2) 'set compatible'の記述が無い事を確認する
広告を非表示にする